Service Degradation - Database Write Operations Unavailable

Incident Report for Pinpoint

Resolved

Component: Pinpoint → Partial Outage

Investigating - 05:00 UTC:
> We are aware that some users may be unable to perform actions that involve saving or updating data. Our engineering team is actively investigating.

Identified - 06:45 UTC:
> The auto-scaling configured on our primary database infrastructure failed to provision additional storage in response to increased load. As a result, the database entered read-only mode, preventing write operations. We are provisioning additional storage to restore full functionality.

Monitoring - 06:57 UTC:
> Additional storage has been provisioned and write operations have been restored. Our team is monitoring to confirm full stability across all services.

Resolved - 07:01 UTC:
> The issue has been fully resolved and all services are operating normally. We apologise for the disruption and are reviewing our auto-scaling configuration to prevent recurrence.
Posted Mar 03, 2026 - 05:00 UTC