Temporary Service Disruption

Incident Report for Pinpoint

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 14:36 UTC

Monitoring

Earlier today, our platform experienced a temporary disruption due to a sudden and highly unusual surge in external traffic, significantly beyond anything we’ve seen before. This caused intermittent 503 errors and degraded performance for approximately 15 minutes.

We acted quickly to contain the issue and restore full service, including scaling our infrastructure and working closely with our edge network provider to bolster caching and traffic protection systems. Service is now fully operational and stable.

We’re continuing to implement further safeguards to ensure that similar patterns of abnormal traffic cannot affect platform availability in the future. While today’s disruption was limited in scope and duration, we recognise the importance of uninterrupted access to Pinpoint - and are treating this with the seriousness it deserves.

We’ll continue monitoring closely and share any further updates here as needed.
Posted Jul 30, 2025 - 11:22 UTC
This incident affected: Pinpoint.