Database Outage Update: Recovery in Progress, Data Backfill Required
All remaining data that was created or modified between 01:00 BST 22nd July and 09:00 BST 22nd July has been restored and is now visible in the platform.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (between 01:00 BST 22nd July and 09:00 BST 22nd July) is now visible in the system.
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.
Posted Jul 23, 2025 - 07:07 UTC
Update
Database Outage Update: Recovery in Progress, Data Backfill Required
Most of the data that was created or modified between 01:00 BST 22nd July and 09:00 BST 22nd July has been restored and is now visible in the platform. This includes all records with the exception of new job applications, which we are currently processing.
We expect that data to be restored within the next hour.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (between 01:00 BST 22nd July and 09:00 BST 22nd July) with the exception of job application data is now visible in the system. Next Steps: We are now restoring remaining job application data that was created or modified between 01:00 BST, July 22nd and 09:00 BST.
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.
Posted Jul 23, 2025 - 06:20 UTC
Update
Database Outage Update: Recovery in Progress, Data Backfill Required
We are still working on restoring all data that was created or modified from 01:00 BST 22nd July (early hours of this morning) up until the point we restored our database at 08:57 BST today.
All missing data is recoverable, it currently just exists in separate database back-ups, and we are working as fast as we can to reconcile the two back-ups.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (last 24 hours) are now visible. Next Steps: We are working to recover and restore data that was created or modified since 01:00 BST, July 22nd this morning.
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.
Posted Jul 22, 2025 - 12:29 UTC
Update
Database Outage Update: Recovery in Progress, Data Backfill Required
We are now working to restore all data that was created or modified from 01:00 BST 22nd July (early hours of this morning) up until the point we restored our database at 08:57 BST today.
All missing data is recoverable, it currently just exists in separate database back-ups, and we are working as fast as we can to reconcile the two back-ups.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (last 24 hours) are now visible. Next Steps: We are working to recover and restore data that was created or modified since 01:00 BST, July 22nd this morning.
Important Note on Performance: - We have returned to normal database infrastructure, meaning the previously reported performance slowdowns should begin to improve load is shared across multiple databases. - We are also experiencing significant slowdowns with the processing of all custom reports
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.
Posted Jul 22, 2025 - 10:12 UTC
Update
Database Outage Update: Recovery in Progress, Data Backfill Required
We have now restored our database to a more recent back-up snapshot (from this morning at 01:00 BST, 22nd July). Any and all records that were in any way created or modified yesterday (from 01:00 BST, 21st July onwards) are now visible once again in the system.
We are now working to restore all data that was created or modified from 01:00 BST 22nd July (early hours of this morning) up until the point we restored our database just moments ago.
All missing data is recoverable, it currently just exists in separate database back-ups, and we are working as fast as we can to reconcile the two back-ups.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (last 24 hours) are now visible. Next Steps: We are working to recover and restore data that was created or modified since 01:00 BST, July 22nd this morning.
Important Note on Performance: - During this recovery process, system performance will be slower than usual. This is because we are temporarily running all operations through a single database while we work to fully restore normal infrastructure. - We are also experiencing significant slowdowns with the processing of all custom reports
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.
Posted Jul 22, 2025 - 08:57 UTC
Update
Database Outage Update: Recovery in Progress, Data Backfill Required
We are still in the process of restoring our database to a more recent back-up snapshot (from 01:00 BST 22nd July) so that the aforementioned missing data from yesterday is fully restored.
Once this second restore has finished, any records created since 01:00 BST 22nd July will still be missing from the system. We will then proceed with restoring this small amount of missing data from today.
All missing data is recoverable, it currently just exists in separate database back-ups. Once our second restore finishes the final part of our restoration involves reconciling the two back-ups.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (last 24 hours) are not yet visible. Next Steps: We are working to recover and restore this missing data.
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.
Posted Jul 22, 2025 - 08:07 UTC
Investigating
We experienced an unexpected outage with our primary database between 01:50 22nd July & 03:40 22nd July. Service has now been restored using a backup. However, the backup we restored from was approximately 24 hours old, which means any data written to the system between 01:00 BST 21st July and 01:00 22nd July is currently missing.
We are in the process of restoring our database to a more recent back-up snapshot (from 01:00 BST 22nd July) so that the aforementioned missing data from yesterday is restored.
Once this second restore has finished, any records created since 01:00 BST 22nd July will be missing from the system. We are actively working to ensure that this small amount of missing data from today is then also restored.
All missing data is recoverable, it currently just exists in separate database back-ups. Once our second restore finishes the final part of our restoration involves reconciling the two back-ups. This process is complex and may take some time to complete. We will continue to provide further updates as progress continues.
Service Availability: Fully restored. Data: Any records created or updated during the affected period (last 24 hours) are not yet visible. Next Steps: We are working to recover and restore this missing data.
We sincerely apologise for the inconvenience this has caused and appreciate your patience while we work to fully resolve the issue.