Some search functionality not available

Incident Report for Pinpoint

Postmortem

We apologise for last week’s disruption to our typically swift and flexible search functionality.

This was caused by routine maintenance of our search infrastructure over the weekend of February 15th and 16th, which encountered unexpected issues during data migration.

The resolution of the issue was further complicated by the larger-than-anticipated size of some datasets and the difficulty of certain technical processes in keeping up.

On Tuesday, February 18th, we also deployed several bug fixes that sped up our data processing and ensured that search failures did not make the UI unusable in some circumstances.

Rest assured, the team has thoroughly reviewed the incident, and changes are already in the pipeline to prevent similar occurrences.

Posted Feb 27, 2025 - 15:41 UTC

Resolved

We have finished rolling out the fix for our search backend, and all search components are 100% functional again.
Posted Feb 18, 2025 - 16:29 UTC

Update

We have restored functionality to 95% of searchable resources and continue to roll out the fix for the remainder.
Posted Feb 18, 2025 - 11:02 UTC

Update

We have identified the cause of the issue and are steadily rolling out the fix.
Posted Feb 17, 2025 - 10:41 UTC

Identified

During routine maintenance to our search infrastructure, an update to the indexed data did not apply correctly, resulting in the inability to search for some resources in the admin application, such as candidates.
Posted Feb 16, 2025 - 16:40 UTC
This incident affected: Pinpoint.